Category Archives: Uncategorized

Ubuntu 12.04 dual boot with Windows 7 on HP EliteBook 8560w

This wasn’t straightforward. It is now working, but nowhere near “out of the box”.

  • The Windows installer (wubi.exe) didn’t work – it just crashed.
  • The installation from CD got stuck – froze on the “copying files” screen.
  • Followed the nomodeset workaround. This allowed the installation to complete.
  • Windows installation on the HP EliteBook had already used up 4 disk partitions. This does not leave a partition free to install Ubuntu. So I deleted the HP “recovery” partition and resized the main windows partition using “disk management” utility in Windows. Other users have recommended deleting the “HP Tools” partition instead. No idea what the consequences of these choices might be.
  • Installation successful. GRUB looks normal. Could boot to Windows, but could only boot to Ubuntu in safe (“recovery”) mode. Booting to Ubuntu in normal mode produced a screen of junk pixels and a freeze every time.
  • Installed recommended Nvidia drivers while in recovery mode, following automatic dialog prompt.
  • Everything seems to be fine.

 

See also: http://beradrian.wordpress.com/2012/06/10/install-ubuntu-12-on-8560w/

Horrible Libre Office bug

I was editing an .odt document using LO Writer, saving periodically. While I was away from the machine, the battery ran out. When I switched on again, the .odt file was still there, but contained 0 bytes of data. The entire contents of the document had been lost. I hadn’t set LO to make backups. The copy on Ubuntu One had already synced to the 0 bytes version. Yikes!

Purely by luck, I had booted to my MS Windows partition on the same machine not too long before the power outage. A previous version of the .odt file had synced to the Ubuntu One folder on the Windows partition and was still there to be retrieved. Phew! Of course, had I booted to the Windows partition after the power outage, with an internet connection, that would have synced to the 0 bytes version as well. Horrible.

This was LibreOffice 3.4.4 on Ubuntu 11.10.

The bug is well known, and has been fixed in a more recent version. But the more recent version is not in the Ubuntu repositories yet.
http://en.libreofficeforum.org/node/2052
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/817326

I am now going to do the following:

  1. get the new version of LO.
  2. review my backup procedures. LO can be set to make automatic backups: Tools > Options > Loan/Save (General) > Always create backup copy. This saves a backup file to ~/.libreoffice/3/user/backup/
  3. wonder what other unpleasant issues might be lurking in LO.

Not Arnold Schoenberg

Nine small ladies with no clothes on, balancing an enormous man with lots of clothes on and his concert grand on their heads… The entire time I was at UCLA I was under the misapprehension that this was supposed to be Arnold Schoenberg, for no better reason than that the UCLA version of the sculpture stands outside Schoenberg Hall. It never seemed very appropriate. Seeing a larger version of the same thing at the NE corner of Central Park, labeled “Duke Ellington”, I thought that this must be an act of self-plagiarism by a sculptor pressed to complete his commissions – knock off another Schoenberg, give him a moustache, call it “Duke Ellington”, and no one need ever know. Weird, but not nine-naked-dwarfettes-holding-a-piano-on-their-heads-weird. But no. I’m now forced to the conclusion that it is Duke Ellington at UCLA too.

Duke Ellington

Nine "muses" effortlessly support Duke Ellington and his piano

Comments on the work of the Old Hanzi Group towards an encoding of OBI script.

This document is a response to an invitation by Suzuki Toshiya and Deborah Anderson to comment on work by the Old Hanzi Group towards an encoding of early Chinese scripts. The comments are based on a review of documents archived on the IRG website:(http://appsrv.cse.cuhk.edu.hk/~irg/), and of the data deposited at ftp://ftp.iso10646hk.net/IRG/OldHanzi/.

Contents:

0. Introduction

1. General remarks

2. Other projects

3. Feasibility of OBI standardization and encoding

4. Why Old Hanzi shoud be encoded separately from CJK

5. Documentation

6. Intended user group, and purpose of encoding

First draft of new paper: “The particle yān 焉, and the phonological reduction of prepositional phrases in Old Chinese.”

First draft is online for circulation and comment. (PDF)

This paper reaffirms Kennedy’s proposal that the particle yān 焉 is, historically, the result of a phonological reduction of a high-frequency PP involving the preposition yú 於 and a 3pp. It further shows that this was part of a more general process which affected high-frequency PPs combining several different prepositions (the discussion will be confined to yú 於, yú 于) and several different 3pps (including zhī 之, shì 是 and hé 何). The MC readings for yān 焉 derive from the PP yúshì 於是. The graph yān 焉 arose from a héwén (合文) writing for the PP yúshì 於是.

The central phonological claim, is that yān < b/qan 焉 derives from the sequence of yú < b/qa 於 and shì < b/deʔ 是, and has attracted some flak from some early readers of the article. I have suggested that the syllable that might be expected, *a/b/qad, which would be prohibited by phonotactic constraints (no voiced stop codas), might have been repaired to the legal b/qan.

Ubuntu 11.10 => HP LaserJet 1200 stopped working

After upgrading to Ubuntu 11.10, my HP LaserJet 1200 refuses to print properly any more. I sometimes get single pages of multi-page documents. I sometimes get “PCL XL error” pages. But usually nothing gets printed at all.

Trying the latest version of HPLIP. The Ubuntu repositories have version 3.11.7. The HP website has version 3.11.12

  1. removed old version of hplip with Synaptic.
  2. downloaded installer from hp.
  3. followed all instructions without incident.

Initially I was back in the same mess as before. However, by repeatedly playing around with deleting the printer connection (System Settings > Printing), adding a new printer connection (System Settings > Printing), and plugging in and out the printer from the USB, and switching it on and off to clear the flashing green light, I managed to get it to work. The problem seems to be that the when the printer gets plugged into the USB, it is recognised automatically, but somehow the connection is incorrectly configured. Now prints just fine from LibreOffice Writer and Evince pdf viewer.

Unfortunately, I’m not sure whether it was the newer hplip version, or the delete/add new printer connection that fixed it.

Install working version of FontForge on Ubuntu 11.10

The version of FontForge currently available from the Ubuntu repositories is unusable with Ubuntu 11.10. The bug and the solution is described here. It seems that FontForge has been fixed to work with 11.10, but that the Ubuntu repositories have not been updated. Version 20110225 works; the older version 20100429 in the repository doesn’t.

Aleksandr’s solution works:

  1. Uninstall the old FontForge package (using Synpatic or whatever).
  2. Install git and python-dev if they are not already installed.
  3. Download and compile FontForge from source:
    Open a terminal screen, and enter the following lines:
    git clone git://fontforge.git.sourceforge.net/gitroot/fontforge/fontforge.
    That downloads the source code for the latest version.
    cd fontforge
    That moves you into the directory where the FontForge files have just landed.
    ./configure
    sudo make install
    That compiles FontForge. The executable was at ~/fontforge/fontforge/fontforge. Change the permissions to run it without sudo.

Ubuntu 11.10 misery

You persuade yourself, and anyone who will listen, that migrating to Ubuntu Linux was a smart move – it’s free, you have control, it doesn’t try and sell you things or manipulate you, it has a short boot-time, you learn more, it isn’t targeted by viruses and malware, it doesn’t use grasping and possessive infantilisms like “My Computer” and “My Music”, it’s fun, you aren’t tortured by shut-down screens that say “Do not unplug or power off your machine – installing updates” that stay there for indefinitely long periods when you need to leave the office with your laptop in five minutes’ time, etc. etc.

Then you upgrade to Ubuntu 11.10…

You can forgive the slightly kindergarten feel of the “Dash”. You reinstall the stuff that gives you back the control you miss from earlier versions. You acknowledge that it actually looks and feels pretty good, and works pretty well.

Then you realise that it cannot, will not, declines to, refuses to, print to your HP LaserJet 1200, which worked just fine with the previous version. You can’t print anything at all! Then you install FontForge, which worked on previous versions, and find that it pulls a segmentation fault whenever you do anything drastic like press the Shift key.

I’m going to start here and here. If they are not both fixed in 24 hrs, I am officially no longer a fan.

Qt + MySQL + Windows 7

Getting Qt and MySQL running together and interacting properly on Windows 7 has been a real headache – much more challenging than on Ubuntu Linux the last time I tried. Without the MySQL drivers for Qt installed, you get the error QSqlDatabase: QMYSQL driver not loaded if you attempt to use a MySQL database. Had I not found the tutorial by ieatbinary I would certainly have been defeated. One way of tackling the problem, it seems, is to get Qt and MySQL up and running independently of one another first, and then to build the MySQL plugin for Qt. Doing that avoids the need to compile all of Qt, including the MySQL driver, from source. Instead one can use the much more friendly installer. There were a few twists, though, which I will summarize here.

Step 1 – Install Qt SDK

Download the installer from http://qt.nokia.com/downloads/. Run it. Note ieatbinary’s (Step 1) point about installing source files, to ensure that you have the source files needed to compile the MySQL plugin.

Step 2 – Install MySQL

Note first that, according to ieatbinary, only 32-bit MySQL can be used to for the Qt plugin. ieatbinary’s tutorial (Step 2) tells us that we need to install the MySQL Client C API Library. I was installing MySQL as part of WampServer and did not find any way of including all of that library during installation. The only file that seemed to be required yet missing was libmysql.lib. This can be retrieved from the ZIP archive downloadable from http://dev.mysql.com/downloads/mysql/. Two different 32-bit archives for Windows were available and only the larger of the two (I used mysql-5.5.19-win32.zip) contained the missing file. Extract the file and copy it to the lib directory of the existing MySQL installation (for me: C:\wamp\bin\mysql\mysql5.5.16\lib).

Step 3 – compile MySQL drivers for Qt

From here on, ieatbinary’s tutorial can be followed exactly. Note that I got a warning (not an error) about unescaped backslashes during the compilation (his Step 4). Didn’t seem to matter.